Mental Ray Vector displacement map/mental Ray

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR
#1
Bonjour tout le monde.

Je teste mudbox 2016 ainsi que mental ray sur max 2016 et je rencontre le message d'erreur suivant au moment du rendu:

SHDR 0.12 165 MB error: A ray encountered an invalid color (NaN), using black instead.

Pour résumé, j'ai un visage low poly que je sculpte dans Mudbox pour ensuite créer une "Vector Displacement Map" de la cible "level 0" à la source "level 3" avec un "Vector Space" en mode "Object"

J'envoie mon modèle low poly dans 3Ds Max auquel j'applique un matériel "Subsurface Scattering Fast Skin+ Displacement".

Au moment du rendu, j'ai les messages d'erreur ci-dessus et rien au rendu.

Si quelqu'un aurait une idée du problème merci d'avance.



 

Gam

Membre très actif
#4
Manifestement Mudbox semble avoir cree des NaN. Ce qui me semble etrange.
1/ option rebake tes vectors en half-float, moins sujet aux Nan.
2/ Si t'a nuke, analyse l'image, pour detecter les NaN, et corrige la a coup de rotopaint.
 
#5
le truc est qu'avec un matériel standard j'ai bien le rendu de mon visage en low poly mais une fois la matériel contenant la VDM appliqué, je n'ai plus le rendu.

J'imagine que ma c'est ma VDM qui déconne soit au moment de la créer sous Mudbox, soit son utilisation sous Mental Ray...
 
#7
Merci pour les conseils.

Apparemment en faisant un extract sous Mudbox de la VDM en EXR 32bit FP, ça marche. je retrouve bien le modèle High poly de mudbox au rendu.

J'étais initialement au format Tif 32bit FP. Pas sur que le problème vienne de là mais le rendu fonctionne.

 
Haut