Compositing Problème de DOF dans AE : flou pas propre

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

adameteve

Membre très actif
#1
Bonjour à tous, :)

J'ai créé une animation de 8 secondes dans 3dsmax (simple travelling).
Je l'ai exportée en OpenEXR via "Separate render channels" (le choix est-il judicieux ?).

J'ai fait le compositing dans AE. Jusqu'ici pas de soucis majeur.

Sauf au moment de créer le DOF avec le plugin Frischluft.
J'ai compris comment appliquer le DOF.

Néanmoins, je constate des lumières parasites autour de la pièce d'échec blanche lorsque je fais la mise au point sur elle (voir captures). Mais lorsque le point est fait derrière cette pièce et qu'elle devient floue, ces parasites disparaissent.


:: CAPTURES ::

- 1. Lorsque la pièce est nette, les parasites apparaissent :


- 2. Lorsque la pièce est floue, les parasites disparaissent :


- 3. Ma passe de Z :


- 4. Les paramètres du ODF :



Est-ce dû à un mauvais paramétrage ?

Merci pour votre aide :jap:
 

adameteve

Membre très actif
#3
Merci pour ta réponse :jap:

Je l'ai exportée en OpenEXR via "Separate render channels" (le choix est-il judicieux ?).
A toi de nous le dire ? tu as testé avec d'autre formats pour vérifier si l'exr te convient le mieux ?
Je voulais dire, par rapport à l'option "V-Ray raw image file" qui crée une seul fichier EXR qu'on doit extraire dans AE.

Concernant la Zdepht, il faut la rendre sans filter.
Sans "filter" ? C'est-à-dire ? Faut-il décocher "Activer filtrage" dans les paramètres des éléments de rendu ?

Merci pour ton aide ;)
 
#6
Je voulais dire, par rapport à l'option "V-Ray raw image file" qui crée une seul fichier EXR qu'on doit extraire dans AE.
Ok.
Persos, je préfère un seul et unique .exr avec tous les layers.

Sans "filter" ? C'est-à-dire ? Faut-il décocher "Activer filtrage" dans les paramètres des éléments de rendu ?
Exemple sur cette image :

Dans la colonne "filter", ta pass de Zdepth doit être sur OFF.

Je sens que tu veux m'en dire davantage mais que tu n'oses pas :D
L'alpha de la passe du Z ?
Ce que Gam veux dire, c'est que tes artefacts apparaissent que dans l'alpha. Donc il y a un soucis d'alpha aussi.
Cependant je viens de voir que tu à vachement coupé ta z avec l'histo, ça doit écrêter à max et donc créer cet artefact. Essaie sans booster l'histo de ta z.

En tout cas, quand je vois ces deux images;


Je trouve que ça viens plus de la z que de l'alpha. (à tester)
Ta DOF, tu la fait une fois ton image compilée ? (RGB)
 

adameteve

Membre très actif
#7
Un grand MERCI pour ton explication détaillée.
J'ai refait un essai en suivant tes conseils, mais le problème persiste.
Je pense que je ne dois pas savoir configurer Frischluft.

Voici la capture de ma compilation :


Problème de paramètrage ?

Merci :jap:
 
#8
As-tu essayer avec un autre outil de DOF dans Ae pour vérifier si ça venais bien du plugin ?

Je pense surtout que ça viens de ton assemblage dans Ae.
Assemble toutes tes images (reflect, direct, indirect, ao...) QUE en rgb, ton alpha doit être plein (vérifie à la pipette que ce soit à 1 partout).
Ensuite applique ta DOF via ta Z en luminance.
Ta z ne doit pas être aussi découpé (comme plus haut) mais plus en valeur de gris.
comme ici :
 
Haut