Mental Ray Pb de shader transparent SIMPLE maya

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR
#1
Bonjour tout le monde,
J'utilise Maya 2012.
J'ai dans ma scene une surface nurbs créée à partir d'une curve que j'ai "revolvée" et jai pour linstant l'eclairage par defaut, donc aucune lampe.
J'ai créé un shader transparent sur lequel jai activé le raytrace.
Quand je rends ma scene avec le rendu par defaut Maya, la transparence apparait impec, et le raytracing est bien là. (que je le rende avec camera ou dans vue persp)
Lorsque je le rends avec MentalRay, mon vase est tout marron opaque. Dapres quelques tests que j'ai pu faire, il semblerait que cela vienne de lombre de mon objet transparent.
Est-ce que c'est clair ? Je pourrais poster un screen demain.
Je suis sure qu'il ny a pas besoin de cocher ou d'activer grand chose pour debloquer cette situation.
En faisant des recherches sur mon probleme, jai vu qu'il y avait beaucoup de soucis de rendu de transparence lorsqu'on utilise un masque (comme pour les feuilles) en texturant la transparence et en jouant sur le canal alpha, mais moi c'est le shader entier qui me pose soucis !
:hello:
 
#3
Le 23.03.12
Ok. Merci. Je le ferais demain car la je suis au taf, en fait jai pas pris de screen car je pensais trouver la soluce sur des anciens sujets ou sur dautres forums mais jai pas vu... :(
(Trop mignon le dejeuner du geek.)

Le 24.03.2012
Hello,
Voila je poste donc mon image avec un rendu maya software a gauche, jolis materiaux transparents..
Et a droite mon rendu Mental ray.
Pour mieux comprendre, j'ai rajouté deux plans de verres dans le vide à droite. Il semble qu'il y a un probleme d'ombres ou de double transparence enfin je ne sais pas trop, je suis un peu perdue... :??:

 

eth3r

Membre très actif
#4
Salut,

Le problème vient peut être de la "profondeur" du raytrace (désolé j'ai pas maya sous la main).
En gros mental ray s'arrete peut a une seul itération de transparence ce qui rend ton objet noir.
Dans rendering-setting/quality/raytrace-option pour refelction depth et refraction depth, met ces deux option au moin 5 6, et le raytrace max égal a la somme des deux précédente option.
Si cela regle ton problème revient modifier le nombre de depth des deux options pour optimisé ton temps de rendu.

Si tu as du final gather même démarche dans les options du FG (max final gather depth etc ... )
 
#5
Salut
Desolée du retard de reponse. En fait jai rencontré a nouveau ce probleme dans une autre scene, et en cherchant sur google, jai retrouvé mon topic, avec ta reponse !
Cest cool, ca ma aidée ! Ya ca et autre chose aussi : avec les materiaux mental ray, il y a une option "Use max distance". En decochant ca, ya pu les problimes de verre noir.



Alors merci pour ta reponse eth3r, mais change donc cette photo :bounce: :pfff:

:hello:
 
Haut