Autre - Divers Changer le comportement du ZOOM

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR
#1
Bonjour à tous, ancien utilisateur de Maya, j'apprivoise peu à peu 3ds Max.
Ces derniers temps, ce qui me ralenti énormément dans ma modélisation c'est le "comportement" du Zoom de la molette:
en effet on dirait qu'il zoome jusqu'à rencontrer un objet, et à partir de là il faut "moletter" comme un fou pour "traverser" cet objet.

Je ne sais pas comme décrire ce comportement, mais disons que sur Maya peu importe ce qu'il y a devant la caméra du viewport, le Zoom va tout traverser sans soucis.
Je fais majoritairement de l'architecture intérieure, donc c'est fort pratique pour éviter de se "cogner" sur le moindre plafond ou mur.

Voilà, j'ai essayé un de regarder sur les internets, mais je n'ai malheureusement pas réussi à trouver ma réponse !
Merci à vous d'éclairer ma lanterne :)
 

phicata

Membre très actif
#2
Crtl+Alt+Molette
C'est le raccourci de l'outil Zoom (la loupe+ en bas à droite=)
Customize/Customize user Interface/Mouse pour personnaliser si besoin.
 
Dernière édition:
#3
Bonjour,

Merci pour ta réponse phicata ! Ca à l'air plutôt efficace ma foi, juste un coup à prendre :)
Alors en effet j'avais été voir dans ces options, mais sais-tu s'il existe un paramètre empêchant la collision d'objet virtuel avec le zoom de la molette ?
 

phicata

Membre très actif
#4
la collision d'objet virtuel avec le zoom de la molette ?
hein? ton doigt n'est pas un objet virtuel, tu n'es pas Néo! :D
A moins que tu ne parles d'une option permettant de "rebondir" contre des objets (comme dans un jeu video): Non
A moins que tu ne parles d'une option permettant que la vue "sectionne" dans les objets à une distance définie: Oui
C'est le "clipping" présent dans les vues perspectives et camera ,c'est juste une option de confort visuel, cela n’affecte pas le rendu, au contraire de l'option
Clipping Planes dans la caméra qui elle, affecte l'image.
Sans titre-1.jpg
 
#5
Si seulement, ça serait beaucoup plus simple ! :D
Oui "rebondir" contre des objets. Par exemple ici, j'essaie de traverser la cheminée pour aller tout simplement dans l'autre pièce, mais la cheminée me bloque le passage :

zoom.gif

Mais si tu me dis que ce n'est pas possible, cela est bien facheux, je vais devoir me contenter du Ctrl + Alt + MMB :(
 

phicata

Membre très actif
#6
De ce que j'en ai compris de max: Ce ralentissement que tu ressent en mode perspective est l'équivalent du rapprochement de la camera de sa target.
Tu t'en rend compte quand tu crée une camera à partir de la vue perspective (Crtl+c), la distance à laquelle ça commence à ralentir équivaut au "target distance" de la camera, si tu l'augmente dans la camera, puis repasse en vue perpective, tu te rends compte que la limite à augmentée. Je sais ce n'est pas très clair et d'autres serraient peut être mieux l'expliquer.
Mais je pense que cette distance dans la vue perspective est une moyenne en fonction du volume occupé par les objets présents, et qu'il te suffirait de mettre un objet quelconque (une simple box non renderable) un peu plus grand , ou juste un peu plus loin, derrière la chambre, pour naviguer plus facilement.
 
Dernière édition:

phicata

Membre très actif
#7
Pour éclaircir....ou pas:
https://knowledge.autodesk.com/fr/s...CCD2C70B-52B4-4BF0-A5C0-74ECC591ACDD-htm.html
"Désormais, le zoom se déplace de façon incrémentielle, en fonction de la distance entre la fenêtre et sa " cible virtuelle ", une cible masquée inaccessible utilisée à des fins de calcul uniquement. Augmentez ou réduisez les incréments à l'aide des touches respectives Ctrl et Alt. Vous pouvez déplacer la cible virtuelle en maintenant la touche Maj enfoncée lors d'un zoom. Dans le cas contraire, vous zoomez de plus en plus près sur la cible immobile."
C'est des mecs de l'ENA qui ont fait l'aide o_O
 
#8
Merci phicata pour tout tes renseignements.
En effet oui j'avais vu cette aide, mais je me méfie parfois des aides Autodesk qui sont parfois un peu... flous :rolleyes:

En vrai je trouve que ce zoom est bien pratique dans certaines situations, ça permet de travailler à plusieurs ordres de grandeurs dans la scène. Mais c'est comme tout, c'est de la pratique :)


Je trouve ça juste dommage qu'il n'a pas mis une option pour le désactiver ! En tout cas merci encore, je pense qu'on peut dire que le problème est résolu ;)
 
Haut