FinalRender Aide sur l'install des alshaders

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR
#1
Salut

J'ai désespérément tenter d'installer les alshaders qui sont des presets pour Arnold
pour ceux qui ne connaissent pas : http://www.anderslanglands.com/alshaders/index.html

Je suis avec Maya 2015 et une version de Arnold 1.2. et l'installation s'avère assez complexe, car peu d'info, et les info existantes se recoupent mal, soit il s'agit de recopier les fichiers aux bons endroit, soit de créér des variables
d'environnement qui pointent vers le dossier, plus la création d'un fichier Maya.env pour écrire ces chemins,
Mais rien n'y fait, j'ai testé plusieurs cas de figure et ne suis pas arrivé "à faire venir" ces shaders dans Maya.

Est-ce que quelqu'un utilise ces preset, et à réussi à les installer

Merci pour toute aide qui sera la bienvenue
 
#2
Salut, pour l'installer c'est simple, tu a la notice disponible en anglais ici: https://support.solidangle.com/display/arnsupp/2014/07/31/[MtoA]+Installing+alShaders
Pour la version française, il suffit de d'extraire le contenue de l'archive dans "C:\solidangle\alShaders", puis d'ajouter les lignes "ARNOLD_PLUGIN_PATH=C:\solidangle\alShaders\bin" et "
MTOA_TEMPLATES_PATH=C:\solidangle\alShaders\ae" de code dans ton maya.env (document/maya/2015-x..) [sans les guillemet bien sur.], puis redémarrer maya et tout est bon. Bon courrage et bonne soirée.
 

Gam

Membre très actif
#3
Il est aussi possible que ca ne fonctionne pas. Les shaders Arnold demandent a etre compiles sur le meme core. La 1.2 commence a dater.
 
#4
Salut

Merci pour ces réponses, J'ai fait exactement ce qui est décris dans la notice et procédé ainsi, mais je ne vois rien. serai t'il possible qu'une fois dans Maya je regarde au mauvais endroit, en principe j'ouvre l'hypershade > Arnold > shaders > et là je devrais trouver qqchose comme un alsurface par ex.

Sinon compiler sur le même core ?
ou changer de version de Arnold pour laquelle - Je n'ai pas très bien en tete quelle version de Maya et de Arnold doivent fonctionner ensemble

merci
 

Gam

Membre très actif
#5
La version que t'as downloader est base sur un core recent. Les shader sont opensource, libre a toi de les compiler avec la derniere lib du core.

Regarde sur qule core est base ta version, et celui des shader.
La derniere version de Mtoa est la 1.4.2.2 base sur le core 4.2.16.3

La tienne en fonction de la version est base entre 4.2.3.1 et 4.2.13.4.

C'est une supposition pour la non compatibilite, ca m'est deja arrive.
Bref c'est une piste
 
#6
Merci

Pour ces pistes, c'est sans doute des problemes de compatibilité.
Ma version d'Arnold est 1.2.1.0 et le core est 4.2.4.0

La version du core de alshader que l'on download actuellement à l'air basé sur la version core 4.2.12.2

J'ai regardé sur le site a download > version history, la dernière version présente de alshader est la 1.0 ORC.12 basé sur le core 4.2.8.0
Ca pourrai etre la bonne solution pour installer ces alshaders

Sinon tu parle de les compiler ? est difficile à faire, je vais faire des recherche sur ce sujet

Merci pour ton aide
 
#8
euh.. oui j'aimerais bien

Mais je pense que ma version d'Arnold ne peu pas trop etre updater parce qu'elle est un peu C......é elle provient de l'école ou je suis en ce moment, car je dois avouer n'avoir jamais réussi à trouver un c....k de Arnold par moi même.

Sinon, j'ai tout de même bien avancé j'ai réussi à installer une version 1.0.0rc11 de alshader basée sur un core 4.2.2.0.
j'ai ensuite testé avec la version juste un peu plus récente la 1.0.0rc12
et là ca ne fonctionne pas, donc c'est bien une histoire de compatibilité !

 
Haut